I have several types of products (boards, cabinets, doors) that we alternately manufacture or sell. I need to add a discriminator field to `product.template` to specify what type of product we're dealing with.
There is already a field called `type` on `product.template`, which has the possible values of product, consu, and service.
To me this field should probably be renamed to `inventory_method` as it better represents the available choices and results, but that is another debate.
If I wanted to add some choices, I'd rename "Stockable Product" to "General Stocked Product" and add a few more options, like "Door", "Cabinet", etc.
For all these new types i'd like them to be treated as stockable.
Would you recommend creating a new field for this kind of disambiguation, or overriding the `type` field? Would that be "safe", in that it would not effect other parts of the inventory system?
↧